Datenschutzerklärung


Direktnachricht



Ihre Software
Details
Excel/VBA 🔍
Add-Ins
Excel/VBA

Excel-Beispiele:
Erklärungen, Formeln, VBA-Code und mehr

Hinweise zu den Beispielen finden Sie hier: Beispiele


Auswahlmenü an ZelleTipp

Kategorie: Tabelle ▸ Datenüberprüfung

(Tipp 246) Nachricht zum Beitrag an Autor Nach oben

Wie kann ich erreichen, daß an einer Zelle ein Auswahlmenü erscheint?

Voraussetzung: Was im Auswahlmenü erscheinen soll, befindet sich in einem Bereich untereinander.

Den Bereich markieren, in dem die Zellen dieses Menü haben sollen.

Anschließend im Ribbon Daten den Button Datenüberprüfung betätigen und im Dialogfeld bei Zulassen den Eintrag Liste wählen. Nun muss nur noch im Feld Quelle der Datenbereich angegeben werden, in dem sich die Angaben befinden.

Entweder in C1 oder in D1 Eingabe möglichTipp

Kategorie: Tabelle ▸ Datenüberprüfung

(Tipp 247) Nachricht zum Beitrag an Autor Nach oben

Wenn in C1 etwas steht, soll in D1 eine Eingabe unmöglich sein und umgekehrt. Wie kann man das realisieren?

  1. D1 aktivieren,
  2. Ribbon Daten ▸ Datenüberprüfung,
  3. Zulassen ▸ Benutzerdefiniert,
  4. eingeben: =(C1=""),
  5. evtl. Fehlermeldung festlegen,
  6. Vorgang für C1 mit =(D1="") wiederholen.

Wenn Quellzelle leer dann Zielzelle leerFormellösung

Kategorie: Tabelle ▸ Datenüberprüfung

(Tipp 186) Nachricht zum Beitrag an Autor Nach oben

Wie kann ich erreichen, daß bei einer Berechnung eine Zahl nur dann erscheint, wenn eine andere Zelle eine Zahl enthält?

Je nachdem, was den Gegebenheiten am besten entspricht:

=WENN(UND(ISTZAHL(A1);ISTZAHL(A2));A1+A2;"")

=WENN(A1="";"";WENN(A2="";"";A1+A2))

=WENN(A1+A2>0;A1+A2;"")